eep error when make program

This forum is used for discussing hardware, software, and technical details of the AVRcam embedded system.

eep error when make program

Postby bear24rw » Sun Apr 08, 2007 6:29 pm

I am able to compile the default code and i'm able to send it to the avr but im not able to track anything after. I get this message in the beginning of make program

> "make.exe" program
avr-objcopy -j .eeprom --set-section-flags=.eeprom="alloc,load" \
--change-section-lma .eeprom=0 -O ihex AVRcam.elf AVRcam.eep
c:\WinAVR\bin\avr-objcopy.exe: there are no sections to be copied!
c:\WinAVR\bin\avr-objcopy.exe: --change-section-lma .eeprom=0x00000000 never used
make.exe: [AVRcam.eep] Error 1 (ignored)
avrdude -p atmega8 -P lpt1 -c stk200 -e

But the program still goes through, but i get this message at the end..

avrdude: verifying ...
avrdude: 4252 bytes of flash verified

avrdude done. Thank you.

/usr/bin/sh: -c: line 2: syntax error: unexpected end of file
make.exe: *** [program] Error 258

> Process Exit Code: 2

the message at the beggining is leading me to beleive somthing is getting messed up with the eep which might explain why i cant track anything (doesnt store color map right)

[edit]im using avrdude 5.3.1[/edit]

Any suggestions would be helpful


After reading around I figured I should probably be using 4.4 of avrdude.. and i just realized that you included the install for the correct winavr version.. after i changed the makefile everything works great now

Posts: 1
Joined: Wed Mar 21, 2007 8:09 pm

Return to AVRcam Embedded System

Who is online

Users browsing this forum: No registered users and 1 guest